Firefox 4 tip: Get disabled add-ons working again

 

It’s a safe bet that Firefox 4 will disallow some of your favorite add-ons.


 

March 28, 2011, 01:49 PM —  PC World —

I’m trying hard to like Firefox 4, but the new browser keeps finding ways to annoy me. First, it moved the Reload button for no good reason (same for the Home button, but that’s just as easily fixed). Second, it put the tabs at the top of the screen (again, easily fixed). Third, I’d swear it runs slower than Firefox 3.6, at least when it comes to starting up and loading pages.

All that’s small potatoes. My real problem with Firefox 4 is incompatible add-ons (a.k.a. extensions), of which I encountered about a dozen after installing the update. Without the likes of PermaTabs Mod, Flstflip, and Craigslist Image Prefetcher, I might as well run Internet Explorer!

Fortunately, there’s a way to turn off Firefox’s compatibility check, which is what blocks these add-ons from running. A word of warning, however: while some or all of your “incompatible” add-ons may indeed run just fine in Firefox 4, there’s a potential downside: one or more of them might wreak havoc, preventing the browser from running properly or even running at all. Try this at your own risk. (FWIW, I’ve encountered no problems on my system.)

1. Open a new tab, type about:config in the address bar, and press Enter.

2. Right-click anywhere in the main window, then click New, Boolean.

3. Copy and paste in the following preference name: extensions.checkCompatibility.4.0

4. Click OK, then set the value to False (which is the default).

5. Exit and restart Firefox.

Now you should have full access to all your add-ons (and plug-ins).

By the way, if you don’t want to take the risk of messing up your browser, your only option is patience: most developers can and will update their add-ons to be compatible with Firefox 4, but you never know how long it will take.

“Update”

Also for Firefox

Add-on Compatibility Reporter 0.8.2  https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/

More about this add-on

After installing the Add-on Compatibility Reporter, your incompatible extensions will become enabled for you to test whether they still work with the version of Firefox or Thunderbird that you’re using. If you notice that one of your add-ons doesn’t seem to be working the same way it did in previous versions of the application, just open the Add-ons Manager and click Compatibility next to that add-on to send a report to Mozilla.

Enjoy

Douglas Beard

 

 

Advertisements

About skicat56

Snow Sports Industry veteran – Husband – Father – Network IT Ninja & Former Powncer. Old enough to know better but young enough to start a new career.
This entry was posted in Firefox and tagged , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s